A security vulnerability has be found in all versions of the Joomla extension eXtplorer 2.1.4 and under.  Version 2.1.5 has been released and this video will show you how to update your Joomla site with the latest version of the extension.

ss jt update extplorer