joomla logoHot on the heels of last week's very important security release, Joomla version 3.4.7 was released today.

This is a security patch which addresses one high priority and one low priority security issue. You can read more about this update on the Joomla web site here.

We have already updated a couple of the Cybersalt Joomla sites and found no problems with this update.  We have since proceeded to update the remainder of our sites plus those of our clients who have who have hired Cybersalt to maintain their Joomla installs (a service we offer for $4.95 per month.)

It is strongly recommended that you update your Joomla installs to version 3.4.7. If you are interested in having Cybersalt maintain your Joomla installs for you, please e-mail This email address is being protected from spambots. You need JavaScript enabled to view it..